Lỗi cài đặt Magento với XAMPP v1.7 (PDO_MYSQL)

(AlperTek) Khi cài đặt magento với XAMPP v1.7, sau khi khai báo đúng các thông số CSDL, nhấn next sẽ gây ra lỗi với apache. Nguyên nhân là Magento sử dụng Zend Framework, Zend sử dụng thư viện PHP PDO để kết nối tới MySQL, thư viện php_pdo_mysql lỗi nên gây ra lỗi trên.

Cách khắc phục:
– Download: http://windows.php.net/downloads/snaps/php-5.2-win32-VC6-x86-latest.zip
– Giải nén rồi copy libmysql.dll vào thư mục xampp\apache\bin và xampp\php.
– Khởi động lại apache là ok

Lỗi trên cũng xảy ra với magento khi nâng cấp XAMPP lên v1.7

Tham khảo:
Magento does not work anymore after upgrading to Xampp 1.7
Instructions to fix MySQL/PHP PDO on 1.7
Installing on Windows with XAMPP and WAMP

laituancuong

,

Gửi phản hồi

Mời bạn điền thông tin vào ô dưới đây hoặc kích vào một biểu tượng để đăng nhập:

WordPress.com Logo

Bạn đang bình luận bằng tài khoản WordPress.com Log Out / Thay đổi )

Twitter picture

Bạn đang bình luận bằng tài khoản Twitter Log Out / Thay đổi )

Facebook photo

Bạn đang bình luận bằng tài khoản Facebook Log Out / Thay đổi )

Google+ photo

Bạn đang bình luận bằng tài khoản Google+ Log Out / Thay đổi )

Connecting to %s